Linux Installation Guide

From Rubygame

Jump to: navigation, search
(Debian, Ubuntu, etc.: Must install dev packages instead)
(Installing Library Dependencies)
Line 5: Line 5:
  sudo apt-get install ruby ruby-dev irb ri rubygems
  sudo apt-get install ruby ruby-dev irb ri rubygems
  sudo apt-get install libsdl1.2-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev
  sudo apt-get install libsdl1.2-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev
 +
 +
=== Fedora ===
 +
 +
su -c "yum install ruby rubygems"
 +
su -c "yum install SDL-devel SDL_gfx-devel SDL_image-devel SDL_mixer-devel SDL_ttf-devel"
=== Gentoo ===
=== Gentoo ===

Revision as of 16:09, 20 June 2010

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox