Page 1 of 1

Bouncy Hopper

PostPosted: Wed Jul 14, 2010 6:04 pm
by blue-wiz
This is the first game I've made with rubygame. It is currently at version 0.2 and there are many more improvements which I can come up with.

129.png
Screenshot :)
129.png (39.29 KiB) Viewed 3838 times


I apologise for the graphics. (Tom's going to kill me for saying that :D)

All the code is released under GPL v3 so feel free to have a look.

Could you all please tell me what you think and I will be posting updates as I make them.

How to install/run:

install the 'rubygame' gem and all of it's dependencies.
install the 'chipmunk-ffi' gem.

Controls:

Left/Right: Roll left and right
Space (hold to charge): do a super jump next time you land.

Re: Bouncy Hopper

PostPosted: Wed Jul 14, 2010 7:08 pm
by jacius
Hahaha, that's great! Now it needs some crazy sound effects. Boing! :lol:

One minor issue: I had to edit the source to get it to run, because you're using YAML without ever explicitly loading it. You can fix that by adding this line somewhere near the start of init.rb:

Code: Select all
autoload :YAML, 'yaml'

Other than that, it's looking good. Let us know when the next version is ready! :D

Re: Bouncy Hopper

PostPosted: Thu Jul 15, 2010 3:52 pm
by shawn42
Hey! looks great. Congrats on your first public release of Bouncy Hopper. It's always nice to see people do cool things with your libraries (chipmunk-ffi), I bet jacius gets that all the time. :lol:

Good work!

Re: Bouncy Hopper

PostPosted: Thu Jul 15, 2010 4:24 pm
by blue-wiz
Thanks guys for the great feedback :D

I set you all a challenge. Without cheating, complete level 2 ;). Incredibly difficult.