Forums Archived

The forums are being archived. See this topic for more information.

Need help with installing rubygame in Win7

Get help and support with Rubygame

Need help with installing rubygame in Win7

Postby drew776 » Wed Feb 10, 2010 7:38 am

Hello,

I am trying to install rubygame in Win 7 and am having some problems.
After typing "gem install rubygame" in the command line I have been getting several kinds of errors:

undefined define method manage_gems
failed to build native gem extension

I recieve the error:

makefile(182) : fatal error U1002: syntax error : invalid macro invocation '$'

after I installed the nmake15.exe file.

I've downloaded all the appropiate .dll's that I found online and even tried the SDL_gfx from the wiki Windows Installation Guide, which was provided by bmatthew1. I've also tried installing different version of rubygame, such as -v2.1.0 up to 2.6.2, and still no luck.

As I'm sure you can tell I do not have much programming experience but I am very interested in learning more. Any help would be greatly appreciated.
drew776
 
Posts: 3
Joined: Wed Feb 10, 2010 7:29 am

Re: Need help with installing rubygame in Win7

Postby drew776 » Wed Feb 10, 2010 9:29 pm

UPDATE:

Ok, so I trued to install rubygame from the very begining again, following the directions on the web page "http://rubygame.org/wiki/Windows_Installation_Guide" exactly.

I then typed "gem install rubygame" and it said I needed to install rake. So I typed "gem install rake"
and it installed rake with no problems. I then tried "gem install rubygame" again, and this time got this error message:

Errir installing rubygame:
Error: Failed to build gem native extension.

C:/Ruby/bin/ruby.exe extconf.rb install rubygame
checking for rb_thread_blocking_Region()... no
creating extconf.h
creating Makefile

nmake
'nmake' is not recgonized as an internal or external command,
operable program or batch file.

Gem files will remain installed in C:/Ruby/lib/ruby/gems/1.8/gems/ffi-0.6.0 for inspection.
Results logged to C:/Ruby/lib/ruby/gems/1.8/gems/ffi-0.6.0/ext/ffi_c/gem_make_out

I dont know what this means or how to fix this problems. Again, any help would be greatly appreciated.
drew776
 
Posts: 3
Joined: Wed Feb 10, 2010 7:29 am

Re: Need help with installing rubygame in Win7

Postby jacius » Wed Feb 10, 2010 11:33 pm

It seems that there is a problem with the latest version of Ruby-FFI on Windows. Please try installing an earlier version with this command:

Code: Select all
gem install ffi --version "<0.6"

Then try installing Rubygame again (with "gem install rubygame").
User avatar
jacius
Site Admin
 
Posts: 131
Joined: Fri Feb 06, 2009 11:13 pm

Re: Need help with installing rubygame in Win7

Postby drew776 » Thu Feb 11, 2010 6:49 am

Your suggestion worked!
Rubygame installed successfully. Thank you very much!
drew776
 
Posts: 3
Joined: Wed Feb 10, 2010 7:29 am


Return to Help & Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron