Forums Archived

The forums are being archived. See this topic for more information.

Error installing Rubygame Mac Pac

Get help and support with Rubygame

Error installing Rubygame Mac Pac

Postby aureyano » Mon Jan 04, 2010 12:44 am

I just tried to install the macpac, but I got an error message.

error installing ffi gem
ffi requires rake (>= 0.8.7, runtime)

error installing rubygame:
ffi requires rake (>= 0.8.7, runtime)

I have no idea what this means. Any thoughts?
aureyano
 
Posts: 3
Joined: Sun Jan 03, 2010 11:37 pm

Re: Error installing Rubygame Mac Pac

Postby jacius » Mon Jan 04, 2010 5:28 am

Rubygems is supposed to install the dependencies automatically, so I'm not sure why it didn't in this case.

Anyway, you should be able to fix it by running the command "sudo gem install rake". Then try installing the Mac Pack again. :)
User avatar
jacius
Site Admin
 
Posts: 131
Joined: Fri Feb 06, 2009 11:13 pm

Re: Error installing Rubygame Mac Pac

Postby aureyano » Sat Jan 09, 2010 7:54 pm

You are a genius! Thanks!
aureyano
 
Posts: 3
Joined: Sun Jan 03, 2010 11:37 pm

Re: Error installing Rubygame Mac Pac

Postby aureyano » Sun Jan 10, 2010 12:16 am

Another error when I run my

rsdl helloworld.rb

I get this

dyld: Library not loaded: /usr/local/lib/libSDL-1.2.0.dylib
Referenced from: /usr/local/bin/rsdl
Reason: image not found
Trace/BPT trap

Any thoughts??
aureyano
 
Posts: 3
Joined: Sun Jan 03, 2010 11:37 pm


Return to Help & Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron