Forums Archived

The forums are being archived. See this topic for more information.

Can't get demo games to run

Get help and support with Rubygame

Can't get demo games to run

Postby salsasalsa » Mon Feb 14, 2011 4:49 pm

I followed all of the instructions and installed all the dependencies and still am not able to get the demo's to work.

I get this error:
------------------
demo_rubygame.rb:25:in `require': no such file to load -- rubygame (LoadError)
from demo_rubygame.rb:25

Rubygame via the command line:
--------------------------------------------------
sudo gem install rubygame
Successfully installed rubygame-2.6.4
1 gem installed
Installing ri documentation for rubygame-2.6.4...
Installing RDoc documentation for rubygame-2.6.4...

RSDL via the command line:
(had to add archflags due to 64 bit)
-------------------------------------------
sudo env ARCHFLAGS='-arch x86_64' gem install rsdl
Building native extensions. This could take a while...
Successfully installed rsdl-0.1.4
1 gem installed
Installing ri documentation for rsdl-0.1.4...
File not found: lib
ERROR: While generating documentation for rsdl-0.1.4
( It seems that the documentation did work for some reason)

Darwinports via the command line:
----------------------------------------
sudo port install libsdl
Warning: port definitions are more than two weeks old, consider using selfupdate
---> Computing dependencies for libsdl
---> Cleaning libsdl

I'm fairly certain that is all I need and everything installed correctly, what am I missing?
salsasalsa
 
Posts: 2
Joined: Mon Feb 14, 2011 3:44 pm

Re: Can't get demo games to run

Postby jacius » Mon Feb 14, 2011 7:00 pm

My guess is that Rubygems is not being loaded, which would mean Ruby doesn't know where to look for Rubygame. Please try running this command to see if it helps:

Code: Select all
rsdl -r rubygems demo-rubygame.rb
User avatar
jacius
Site Admin
 
Posts: 131
Joined: Fri Feb 06, 2009 11:13 pm

Re: Can't get demo games to run

Postby salsasalsa » Mon Feb 14, 2011 7:35 pm

ruby -r rubygems demo_rubygame.rb
Warning: Could not load SDL_gfx! Continuing anyway, but some Surface methods will be missing.
Error message was: "Could not load SDL_gfx."
Warning: Could not load SDL_image! Continuing anyway, but image loading will be missing.
Error message was: "Could not load SDL_image."
Warning: Could not load SDL_mixer! Continuing anyway, but audio features will be missing.
Error message was: "Could not load SDL_mixer."
Warning: Could not load SDL_ttf! Continuing anyway, but the TTF class will be missing.
Error message was: "Could not load SDL_ttf."
demo_rubygame.rb:55: This demo requires Surface rotozoom and zoom support (SDL_gfx) (RuntimeError)

Looks like SDL wasn't working properly. Investigating how to fix this now.
salsasalsa
 
Posts: 2
Joined: Mon Feb 14, 2011 3:44 pm


Return to Help & Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron