Page 1 of 1

Rubygame doesn't work

PostPosted: Wed Jan 12, 2011 4:58 pm
by Orvi
Hi! I 've just finisched to teach myself ruby and now i'd love to program games with it.
I've got 2 computers : a Ubuntu and a Solaris.. and I tried to install rubygame in them.
Fist i Installed rubygems and it works on both Computers. then I tried to install ruby game as root and it gives me this loooong error.

antonio@opensolaris:~/Desktop# gem list --local

*** LOCAL GEMS ***

rake (0.8.7)
antonio@opensolaris:~/Desktop# gem install rubygame
Building native extensions. This could take a while...
ERROR: Error installing rubygame:
ERROR: Failed to build gem native extension.

/usr/ruby/1.8/bin/ruby extconf.rb
checking for ffi.h in /usr/local/include... no
checking for rb_thread_blocking_region()... no
checking for ruby_thread_has_gvl_p()... no
checking for ruby_native_thread_p()... no
checking for rb_thread_call_with_gvl()... no
creating extconf.h
creating Makefile

make
make: Fatal error in reader: ./libffi.gnu.mk, line 15: Unexpected end of line seen


Gem files will remain installed in /var/ruby/1.8/gem_home/gems/ffi-1.0.4 for inspection.
Results logged to /var/ruby/1.8/gem_home/gems/ffi-1.0.4/ext/ffi_c/gem_make.out


IT's STRANGE ISN'T IT?

Re: Rubygame doesn't work

PostPosted: Fri Jan 14, 2011 12:51 pm
by sgrevan
Hi,

Semms like make failed to compile ffi, which is a dependency of rubygame.

There's a newer version of ffi available (1.0.5), I just compiled it successfully on Arch 64 bits.
Give it a try :)

If it fails again, your system probably miss some toolchain components (gcc make bison fakeroot ?).

Hope it helps.