Strict Standards: Non-static method phpbb_feed_factory::init() should not be called statically in /home/jacius/rubygame/forums/feed.php on line 66
[phpBB Debug] PHP Notice: in file /feed.php on line 171: Cannot modify header information - headers already sent by (output started at /feed.php:66)
[phpBB Debug] PHP Notice: in file /feed.php on line 172: Cannot modify header information - headers already sent by (output started at /feed.php:66)
Rubygame Forums 2010-12-28T04:53:45+00:00 http://rubygame.org/forums/feed.php?f=4&t=184 2010-12-28T04:53:45+00:00 http://rubygame.org/forums/viewtopic.php?t=184&p=704#p704 <![CDATA[Re: A Problem with installing Rubygame]]>

Statistics: Posted by Rusty — Tue Dec 28, 2010 4:53 am


]]>
2010-12-26T15:54:12+00:00 http://rubygame.org/forums/viewtopic.php?t=184&p=701#p701 <![CDATA[Re: A Problem with installing Rubygame]]>
Code:
sudo gem install ffi --version 0.6.3
sudo gem install rubygame


Hope that helps.

Statistics: Posted by aeonofdiscord — Sun Dec 26, 2010 3:54 pm


]]>
2010-12-19T06:18:58+00:00 http://rubygame.org/forums/viewtopic.php?t=184&p=690#p690 <![CDATA[Re: A Problem with installing Rubygame]]> I'm considering trying out PyGame instead too, I've been googling trying to figure out Rubygame and get help with this for a day now with no luck. Hell, even C++ and a good framework would be better than trying to figure out Rubygame at this point in my opinion.

Not to mention, The Rubygame Book is not only astonishingly incomplete, but contains counter-productive code samples (naming errors, argument errors, its non-operable, it looks like amateur hour at your local highschool infotech class).
Not only is there a LACK of documentation and games for Rubygame, but the documentation that does exist gives inaccurate instructions.

Maybe when the community is bigger it will be easier for people like us to install and use Rubygame.
Oh well.

Statistics: Posted by click170 — Sun Dec 19, 2010 6:18 am


]]>
2010-12-18T20:18:17+00:00 http://rubygame.org/forums/viewtopic.php?t=184&p=689#p689 <![CDATA[Re: A Problem with installing Rubygame]]>

Statistics: Posted by kettuvaloinen — Sat Dec 18, 2010 8:18 pm


]]>
2010-12-08T16:57:29+00:00 http://rubygame.org/forums/viewtopic.php?t=184&p=685#p685 <![CDATA[A Problem with installing Rubygame]]>
Code:
sudo gem install rubygame

And I got following error message:
Code:
ERROR:  Error installing rubygame:
   ffi requires Ruby version >= 1.9.2.

I got Ruby1.9.1 at that time and with help from #ubuntu irc channel I installed Ruby1.9.2 by following instructions from website:
http://www.ubuntuupdates.org/ppa/pratik ... ruby_1.9.2
Also this website contains how to install ruby1.9.2:
http://ubuntuforums.org/showthread.php?t=1560070

After I did according to the last link compiling ruby1.9.2 from source I got following error messages when 'sudo gem install rubygame':
Code:
ERROR:  Loading command: install (LoadError)
    no such file to load -- zlib
ERROR:  While executing gem ... (NameError)
    uninitialized constant Gem::Commands::InstallCommand


When compiling from the source I didn't do 'install' between 'make' and 'sudo make install'.

But still I get that same error message. Can anyone help me with this issue? :(

Statistics: Posted by kettuvaloinen — Wed Dec 08, 2010 4:57 pm


]]>